Cek IP Dinamis

From AbahDoku Wiki

Script untuk 1 DNS[edit]

:local dnsName "nama.dns.net";
:local hotspotHostAddress [/ip hotspot ip-binding get [find comment="nama.dns.net"] address];
:local dnsStaticValue [/ip dns static get [find name="cctv.bele.net"] address];
:local bot "BOOT_TOKEN";
:local chatID "CHAT_ID";
:if ($hotspotHostAddress != $dnsStaticValue) do={
 /ip dns static set [find name="cctv.bele.net"] address=$hotspotHostAddress
 :local message "IP pada DNS statis $dnsName telah berubah menjadi $hotspotHostAddress"
 /tool fetch url=("https://api.telegram.org/bot$bot/sendMessage\?chat_id=$chatID&text=$message") keep-result=no
} else={
 :local message "IP DNS statis $dnsName tidak berubah: $hotspotHostAddress"
 /tool fetch url=("https://api.telegram.org/bot$bot/sendMessage\?chat_id=$chatID&text=$message") keep-result=no
}

Script untuk banyak DNS[edit]

:local dnsNames { "mainar.albait.net" ; "ipang.albait.net" ; "dokter.albait.net" ; "pondok.albait.net" ; 
 "armbian.albait.net" ; "cctv.albait.net" };
:local bot "1931317277:AAFRdZ_pexR03lA_MHmwU3_T8RCx80_Sm7s";
:local chatID "1952568357";
:foreach dnsName in=$dnsNames do={
  :local hotspotHostAddress [/ip hotspot ip-binding get [find comment=$dnsName] address];
  :local dnsStaticValue [/ip dns static get [find name=$dnsName] address];
  :if ($hotspotHostAddress != $dnsStaticValue) do={
    /ip dns static set [find name=$dnsName] address=$hotspotHostAddress;
    :local message "IP DNS statis $dnsName telah berubah dari $dnsStaticValue menjadi $hotspotHostAddress";
    /tool fetch url=("https://api.telegram.org/bot$bot/sendMessage\?chat_id=$chatID&text=$message") keep 
result=no;
  } else={
    :local message "IP DNS statis $dnsName tidak berubah: $hotspotHostAddress";
    /tool fetch url=("https://api.telegram.org/bot$bot/sendMessage\?chat_id=$chatID&text=$message") keep- 
result=no;
  }
}